GCC-High Licensing Provisioning Slowness

Incident Report for CyberSheath

Resolved

We've observed over the last 7 days that licensing turnaround times are back to normal.
Posted Mar 20, 2026 - 09:44 EDT

Identified

Microsoft has notified CyberSheath that there is an extended delay (up to 7 business days) in all Microsoft 365 licensing provisioning for net-new and additional license adds.

We will provide another update as one is made available from Microsoft, or when we begin to observe faster licensing turnarounds.

Commercial and GCC environments remain unaffected.
Posted Feb 25, 2026 - 08:58 EST
This incident affected: Microsoft 365 GCC-High.